add new task       

Task ID:  6182  Crop missing from Micromet xml    
 
Created by har297 on 2016-09-26 8:36 PM, 514 days ago
Project:  Module Code
Category:  Bug
Priority:  [no priority]
Assigned to:  [not assigned]  
Status:  closed
Apsim Version:7.8
Your Name:
Contact Details:
 
 

show inline images      show change history

 comment 42596 posted by har297 on 2017-04-21 5:13 PM, 307 days ago 

Ok, I installed last revision and it is ok now. Must have been fixed indirectly in the wash. Thanks for looking at it.

6199 looks to be ok now too.

 comment 42575 posted by hol353 on 2017-04-21 12:58 PM, 307 days ago 

Tried to reproduce but couldn't. Attached is my attempt.

file 42574 attached by hol353 on 2017-04-21 12:57 PM, 307 days ago 

attachment: Test.apsim   view   save

size: 39980   content-type: application/octet-stream

 comment 42566 posted by har297 on 2017-04-20 5:13 PM, 308 days ago 

Mucuna is in the xml but when Mucuna is in the paddock tree along with Micromet a fatal error occurs wen you run the simulation. Similarly for Soybean and Peanut (ref ID 6199). It is simple to test - load in any simulation, add micromet with an ini component pointing to the micromet.xml. Add mucuna and run. In the Summaryfile component there is "Cannot find crop: mucuna".

This is a problem when running Plant2 and Plant crops in the same paddock. e.g. Taro2 and Mucuna.

 

 comment 42553 posted by hol353 on 2017-04-20 3:20 PM, 308 days ago 

John, If you supply an updated micromet.xml file I'll add it (attach it to this issue if you like). Alternatively, if you can tell me what to add I can do that.

 

 comment 42460 posted by har297 on 2016-09-26 8:36 PM, 514 days ago 

Mucuna is missing from the Micromet xml. Very likely there are other crops missing that cause fatal errors.