add new task       

Task ID:  4137  Installer needs update    
 
Created by her123 on 2016-03-23 12:12 PM, 879 days ago
Project:  Module Code
Category:  Minor
Priority:  [no priority]
Assigned to:  zur003  
Status:  closed
Apsim Version:7.8
Your Name:
Contact Details:
 
 

show inline images      show change history

 comment 42565 posted by zur003 on 2017-04-20 4:47 PM, 486 days ago 

And on the eve of the release of 7.9, we find that it you've installed VS 2017, the installer gets confused about versions of the C++ runtime. I've had to tinker a bit on Bob, but it should be working OK now (although it means everyone running the installer will be upgraded to the 2017 version of the runtime). Closing this taks for now, but it may need reopening if testing reveals major problems.

 comment 42508 posted by zur003 on 2017-02-07 11:05 AM, 558 days ago 

Turns out that Microsoft has bugs in their configuration for downloading the VC redistributable in VS 2015. For more information, see https://connect.microsoft.com/VisualStudio/feedback/details/1604832/vcredist-bootstrapper-packages-in-vs-2015-sdk-arent-working,

I've re-configured Bob so this should now be working correctly (though testing is still in progress).

 comment 42506 posted by zur003 on 2017-02-06 8:47 AM, 559 days ago 

Blast! My attempt to correct this in R3995 didn't work as expected. Although I get sensible installers when building on my own desktop, the builds on Bob aren't checking for the correct C++ runtime (and even appear to be trying to install a 16-bit version!). More work needed here.

 comment 40327 posted by her123 on 2016-03-23 4:21 PM, 879 days ago 
Current libxml is old and keeps requiring vc90 runtime. Should be using libxml 2.7.8
 comment 40294 posted by her123 on 2016-03-23 12:12 PM, 879 days ago 
The installer 7.7 still tries to install VSC++ 2008 runtime.
Also wants to keep installing VSC++ 2010 every time under Win 8 and Win 10.