add new task       

Task ID:  1031  Putting an ini into the ApsimUI doesn't work in new beta.    
 
Created by hol353 on 2009-09-15 9:36 AM, 3169 days ago
Project:  User Interface
Category:  Bug
Priority:  high
Assigned to:  hol353  
Status:  closed
Apsim Version:7.1beta
Your Name:Rogerio Cichota
Contact Details:
Rogerio.Cichota@agresearch.co.nz
 
 

show inline images      show change history

 comment 30867 posted by hol353 on 2009-09-17 2:39 PM, 3167 days ago 
I couldn't reproduce this bug.
 comment 30835 posted by hol353 on 2009-09-15 9:36 AM, 3169 days ago 
Hi Dean,
I was not sure if the Google groups would be the best place for this question, since it is about APSIM 7.1.
The question: is it possible to call a xml file using the new APSIM version (with initial parameters for example)?
In version 7 we managed to get SWIM working with the UI, we have to add xml files (the type files) using something like commands below in the .apsim file:
      <SWIM2>
        <ini name="SWIM_Props">
           <filename>Horotiu_SWIM.xml</filename>
        </ini>
      </SWIM2>
I believe you and Val worked this out. It was good because I could have the parameter files called from the interface and even change it there.
I tried to use the same <ini> thingy in version 7.1, it does show the file in the interface, but apsim no longer reads the file when running the simulation. I managed to make SWIM work in the new version, but I had to create new types (saved the xml with new names) and add them to a personal toolbar. This is not ideal for swim because it has a parameter file that is soil specific, so it would be good to call that file in the interface instead of changing the whole xml. Is there any way to do this in version 7.1?